Recent Posts

Pages: [1] 2 3 ... 10
1
SlickEdit® / Re: Drag-n-drop seems broken on Linux (again)
« Last post by JeffB on Today at 08:56:55 pm »
My bad...somewhere along the way the config setting got turned off. I don't know how (it's been on for years).  Anyway, it's working now.  Thanks!
2
SlickEdit® / Re: macOS, v26 crash on Menu: Edit -> Fill
« Last post by patrick on Today at 08:55:38 pm »
Is it an Intel or Apple Silicon system?  We haven't reproduced it with the Big Sur or Monterey systems yet.

Is there a crash report in the Console app that has a stack for the crash?  If so, post that, might give a hint.

And does it crash if you do the same thing after starting SlickEdit from the terminal, like this: open -a SlickEditPro2021.app --args -sc /tmp/empty_config/
3
SlickEdit® / Re: Drag-n-drop seems broken on Linux (again)
« Last post by Clark on Today at 08:40:58 pm »
I just tried my Kubuntu 18.0.4 VM with v26.0.0.6 64-bit Qt4 and could not reproduce this problem.

Please try a default config:

Code: [Select]
vs +new -sc /tmp/new-config-dir&
4
Features and/or Improvements / Re: Git workfolders
« Last post by Dan on Today at 07:42:09 pm »
That is interesting.  We use worktrees here.
5
SlickEdit® / macOS, v26 crash on Menu: Edit -> Fill
« Last post by tuchman on Today at 07:24:52 pm »
This problem is 100% reproducible, macOS 12
1) Create a file containing only a few spaces
2) Select the very first space
3) Menu: Edit -> Fill
4) Enter '!'
5) Crashes in Qt
6
Features and/or Improvements / Git workfolders
« Last post by jporkkahtc on Today at 07:15:10 pm »
So I usually have several clones of a repo that I'm actively working in.
For example:
Code: [Select]
C:\src\projects1\NiftyTool\...
C:\src\projects2\NiftyTool\...
C:\src\projects3\NiftyTool\...
or sometimes
Code: [Select]
C:\src1\projects\NiftyTool\...
C:\src2\projects\NiftyTool\...
C:\src3\projects\NiftyTool\...

Then I bounce around between the different copies.
I primarily work in copy "1", but then I have extra copies for keeping other branches checked out for reference.
Or sometimes I have a couple of different changes in progress in the extra copies.

It would be great if Slickedit would know about this!
Some things Slickedit could do if it knew about this:
  • Use the same workspace/project files across all copies
  • Cycle between the copies of workspaces
  • Cycle between multiple copies of a given file.
  • Diff two versions of a given file/directory

Example:
Often I want to view copy "1" and copy "2" of some file side-by-side. I manually have to
Get the full path of the current file.
On the slick cmd line I do "e <path>", and manually edit the path to get copy 2.
Editing: C:\src\projects1\NiftyTool\src\lib\subdir\blah\ImportantFile.cs
Open 2nd copy: e C:\src\projects2\NiftyTool\src\lib\subdir\blah\ImportantFile.cs


One way slickedit could "know" about this is via git worktrees.
If slick knows it is a git repo, it can query for worktrees and immediately has good information on the multiple copies of the source code.
There are drawbacks to using worktrees, but still - this could be pretty handy.
7
SlickEdit® / Re: Drag-n-drop seems broken on Linux (again)
« Last post by JeffB on Today at 05:34:46 pm »
Kubuntu 18.04.  I just tried the Qt5 version and it does the same thing.  Behavior is same as:
https://community.slickedit.com/index.php/topic,18349.0.html

When you click to drag, it just undoes the current highlighting and starts a new selection.
8
SlickEdit® / Re: Color coding profile 'Ruby': Invalid type 'bqbackslash'
« Last post by Clark on Today at 04:16:57 pm »
Easiest fix is to remove if from user.cfg.xml.

Some config upgrade in the past must have failed.
9
SlickEdit® / Re: Drag-n-drop seems broken on Linux (again)
« Last post by Dennis on Today at 03:48:08 pm »
Which Linux distribution and version?  Have you tried the Qt5 version of v26?
10
SlickEdit® / Re: Git Commit message shows twice in history window
« Last post by Dan on Today at 03:46:08 pm »
Great.  You should notice that we put a column in there for the actual short version hash as well as the comment.
Pages: [1] 2 3 ... 10