Recent Posts

Pages: 1 [2] 3 4 ... 10
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by Dennis on March 23, 2023, 09:12:14 pm »
Do you have better luck with the tool windows if they are docked?  For the Find and Replace tool window, you may need to go to Options > Tool Windows and enable docking for it. 

Also, is the host machine using scaling or native resolution for all your monitors?
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by jorick on March 23, 2023, 08:25:04 pm »
The default configuration didn't work.

The Qt5 version worked a little bit.  I opened the Find and Replace window but nothing showed up until I clicked on the SE main window.  There was a cursor in the Search For text area and I was able to type in it and hit Enter to perform the search or Esc to close the window, but the rest of the box didn't respond.  Clicking anywhere outside the window disabled the text area and I had to close the window by going into Options->Tool Windows and unclicking the Visible box.
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by Dennis on March 21, 2023, 03:05:11 pm »
To start the editor with a default configuration, from the shell:
Code: [Select]
{slickedit_install_dir}/vs +new -sc /tmp/defcon1
That tells SlickEdit to start a new instance and create a new configuration directory under /tmp.

I did not notice that you were using it on WSL.  That may be relevant.  You could also download the Qt5 version and see if that works better under WSL.
This is a limitation. We will try to improve this for v28.
When I enabled "Send Output to Editor Window" in the build tool window, when I do a build the output in the build tool window doesn't automatically show the end of the output of the build. I see it in the editor window but shouldn't the build tool window also show the most recent output of the build and scroll by? It seems to be stuck at the top of the build.
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by jorick on March 20, 2023, 02:58:25 pm »
I assume that starting the editor for the first time after installing starts with a default configuration.  If so, yes, it happens.

The Options dialog is unaffected, and I can move the window and change the options with no problem.  Toolbars work fine, as well as being able to move icons into and out of toolbars and setting up custom icons.  However, if a tool window is open (such as Find and Replace) while the Options window is open to the Toolbar Customization page, the tool window is still not responding, even after I hit Close.

I don't know if you noticed in the SlickEdit information, but I'm running SE on WSL2.
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by Dennis on March 20, 2023, 12:14:06 pm »
Does this also happen if you start the editor with a default configuration?

Is the options dialog active?  This should not affect tool windows, but when you have the options dialog open to the Toolbar Customization page, the toolbars are switched to a special state for adding and moving toolbar icons.  Go to Tools > Options... and hit Close on the options dialog.
I think I've found how to reproduce this issue.

Open the process buffer with:

 edit ("+b  Build (.process)");

Don't have checked in the build window: "Send Output to Editor Window"

Do a bunch of builds while you have the process buffer as an editor tab. Perhaps even do Ctrl+Home in the .process editor tab before a build.

Do this enough times and you will like see the <SOH> in the build output.

It is still happening for me in 27.0.1 on Linux x64.
SlickEdit® / Re: Tool windows don't work (Linux)
« Last post by jorick on March 15, 2023, 02:28:48 pm »
The Find and Replace dialog box doesn't respond either.
SlickEdit® / Tool windows don't work (Linux)
« Last post by jorick on March 14, 2023, 08:36:25 pm »
Tool windows don't allow keyboard or mouse interaction.  They can't be typed in nor any selections with the mouse.  If the main SE window is moved, the tool window moves along with it, but it can't be moved on its own.  All other windows work fine.

SlickEdit Pro 2022 for Linux (v27.0.1.0 64-bit Qt4)

Serial number: VLX_TRIAL
License type: Trial
License expiration: 2023-03-28 20:00:00
License file: /home/benner10/slickedit/bin/slickedit.lic

Build Date: December 7, 2022
Emulation: CUA

OS: Linux
OS Version: Ubuntu 22.04.2 LTS
Kernel Level:
Build Version: #1 SMP Fri Jan 27 02:56:13 UTC 2023
Processor Architecture: x86_64

X Server Vendor: Microsoft Corporation
Window Manager: Weston WM
Display manager: Unknown

Memory: 23% Load, 3516MB/14662MB Virtual
Shell Information: "/home/benner10/slickedit/bin/secsh" -i
Screen Size: 1920 x 1080, 1920 x 1080, 1920 x 1080, 1920 x 1080, 1920 x 1080

Project Type: Single file project - Gnuc
Language: .cpp (C/C++)
Encoding: UTF-8, no signature

Installation Directory: /home/benner10/slickedit/
Configuration Directory: /home/benner10/.slickedit/27.0.1/
Pages: 1 [2] 3 4 ... 10