SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => Topic started by: vandermyer on February 09, 2021, 09:54:20 am

Title: Always get space inserted before ';' when type break (25.0.1.0)
Post by: vandermyer on February 09, 2021, 09:54:20 am
This is not a new issue,  but I guess I have just been typing the word 'break' a lot recently so it has become noticeable. When I type the full word 'break' and then ';'  (language is C) a space is always inserted before the ';', so I get 'break ;'. If I type 'b' then hit the space-bar, I get 'break;' (no extra space inserted). I know the obvious thing to do is to always type 'b' and space-bar to insert what I want, but sometimes I seem to like typing the world in full.

But here is the thing I can't understand: in Options/.../Aliases, I can't find ant expansion for break. So how do I change the expansion to stop the extra space?


Title: Re: Always get space inserted before ';' when type break (25.0.1.0)
Post by: patrick on February 09, 2021, 04:30:19 pm
That does sound strange, I don't know of any setting that would only take effect for break statements.  Can you post your user.cfg.xml from your configuration?  I want to see if I can reproduce it using your config file, and see if I can narrow it down.
Title: Re: Always get space inserted before ';' when type break (25.0.1.0)
Post by: vandermyer on February 10, 2021, 09:05:55 am
User.cfg.xml attached.
Title: Re: Always get space inserted before ';' when type break (25.0.1.0)
Post by: patrick on February 10, 2021, 04:57:16 pm
Glad we got your config, because I wouldn't have been able to reproduce it with my usual setups.  There's a bug here, we're looking into it.  It should be hot-fixable.
Title: Re: Always get space inserted before ';' when type break (25.0.1.0)
Post by: Dennis on February 10, 2021, 10:09:19 pm
Fixed for the next revision of the cumulative hot fix for 25.0.1.