SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit User Macros => Topic started by: chip.dip on October 27, 2012, 12:16:50 am

Title: problem with resize.e
Post by: chip.dip on October 27, 2012, 12:16:50 am
this macro is intended to set the size of each new window.  It does set the size but the text ends up in a smaller rectangle withing the window.

Anyone know what's wrong?

macro and screen dump attached.
Title: Re: problem with resize.e
Post by: Phil Barila on October 27, 2012, 10:55:01 am
What version are you using?  The last few (at least 2, probably more) have a facility to set the new window size in Tools > Options > Editing > Editor Windows.
Title: Re: problem with resize.e
Post by: ehab on October 27, 2012, 11:19:18 am
can someone move this thread to the general section.
Title: Re: problem with resize.e
Post by: TxDot on October 09, 2013, 01:25:08 pm
I know this is an old thread but I see the same behavior as the OP but I don't see an answer. I did notice that as soon as I grab the window frame to manually adjust the size, the scrollbar disappears and the blue vertical line indicator appears (which is what the behavior should be to begin with). This is really screwy!!!

I just upgraded to SE 2011 (I know even that's old) and my old resize.e macro doesn't work as it did in SE 2007. It won't adjust the height or width correctly. It ends up making the width of the window appear as described above and won't adjust the height at all. Sigh...
Title: Re: problem with resize.e
Post by: chrisant on October 10, 2013, 05:17:54 am
For starters, I think the macro needs to use _mdi.p_child._MDIChildGetWindow and _mdi.p_child._MDIChildSetWindow.

The editor code in macros\moveedge.e has plenty of examples.
Title: Re: problem with resize.e
Post by: TxDot on October 10, 2013, 01:24:00 pm
Using _MDIChildSetWindow has resolved the display issue. Thanks!