SlickEdit Community

Archived Read Only Forums => SlickEdit 2015 v20 Beta Discussion => Topic started by: dhylands on October 05, 2015, 08:42:42 pm

Title: Problems launching SlickEdit v20 beta
Post by: dhylands on October 05, 2015, 08:42:42 pm
I'm running Ubuntu 14.04.3 LTS with v20.0.0.4 64-bit.

The very first time I lauch SlickEdit it pops up a dialog with no text on it. I believe this is the dialog which says that's its importing my settings or something. I can see some text flash up (for about a single frame time) just as the dialog is closed.

The second issue I have is that while in version 19, I had the following 2 html files open:;a=blob;f=dom/devicestorage/test/test_fs_remove.html;h=b495e244f186b36afa2a1fb27a764b25b57e9698;hb=HEAD

The first time I launch version 20 (or after removing ~/.slickedit/20.0.0/) then it remembers all of the open files I had in 19, including the html files mentioned above. If I just quit and relaunch slickedit, then I get an error message "Restore: Code page not installed or not valid" and it seems to abort the loading of files (i.e. it only opens some of the files that were previously open).

If I close the html files the first time that I launch slickedit, then I don't get the error and all of the remaining files open successfully.

If I reopen the html files, then everything is fine from then on (i.e. I can quite and restart slickedit and I don't get  the code page error).

The third issuse I ran into is that slickedit (v19 or v20) refuses to run over an ssh -X session. I get the following error printed on the console:

D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/usr/var/lib/dbus/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

Under ubuntu 14.04 there is no /usr/var directory tree. I was able to create a symlink from /usr/var to /var and get this to work. This was reported for version 19 (I found it in the forum), and still doesn't appear to be fixed in version 20.
Title: Re: Problems launching SlickEdit v20 beta
Post by: Clark on October 05, 2015, 09:47:57 pm
We will look into these. Thanks for posting
Title: Re: Problems launching SlickEdit v20 beta
Post by: patrick on October 06, 2015, 02:55:35 pm
For #3, we're going to change how we handle a missing dbus session information, so in the future it should just start.

What's happening is when you login via ssh, there's no dbus session started for that login.  The error message given by the dbus client about linking the machine-id file is trying to be helpful,  but the advice isn't appropriate for this sitation. 

As a workaround, you can either start your own dbus using dbus-launch like this:  dbus-launch --exit-with-session SE_PATH/bin/vs +new ...  One caveat to this is that dbus will not always exit when SlickEdit exits; if that happens, the logout will block trying to wait for it to exit, and you'll have to ctrl-c out of that ssh session. 

The other option is to disable dbus, but in a way that makes SlickEdit continue on after the failed connect:  DBUS_SESSION_BUS_ADDRESS=unix abstract=/tmp/no_such_file SE_PATH/bin/vs +new ...
Title: Re: Problems launching SlickEdit v20 beta
Post by: Clark on October 06, 2015, 09:05:47 pm
I haven't been able to reproduce the "code page not installed or not valid" error. I tried the HTML files you specified (opened them in v19, deleted v20 config, opened them in v20, then restart and v20 still opens them).

Please post your v19 vrestore.slk file. That will let me know what encoding the files were interpreted as. I have a feeling the encoding will be different than what I'm getting.

I did notice that v19 and v20 weren't supporting the new HTML5 style encoding specified at the top of one of the files. One of the files should have be opened in Utf-8 encoding. That will be fixed in the next beta.
Title: Re: Problems launching SlickEdit v20 beta
Post by: dhylands on October 07, 2015, 01:10:51 am
You can find a copy of my vrestore.slk file here: