SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => Topic started by: btrey on October 22, 2006, 04:32:43 pm

Title: Basic questions
Post by: btrey on October 22, 2006, 04:32:43 pm
Brand new to Slickedit and having trouble getting started.  A couple of basic questions.

First, what is the VSLICKERRORPATH variable?  It keeps showing up in build outputs and I don't know if it's normal, an indication that something's wrong, or what.  Searching the help file and the web site gets zero hits.

Second, I'm running on Linux.  A lot of the default configs seem to still be configured for a Windows setup.  Among other things, my build output windows is full of this (username objuscated):

(Merlin:~/projects/sedit) xxxxxx% echo VSLICKERRORPATH="/home/xxxxxxx/projects/sedit/"

This looks like some sort of color codes but they obviously aren't working.  Is this something that's Windows specific (they remind me of old DOS ANSI-SYS codes) or do I perhaps need some package installed on my Linux system that isn't there?  I can't find anything in any of the options dialogs which looks like it might apply.

Title: Re: Basic questions
Post by: hs2 on October 22, 2006, 07:56:03 pm
VSLICKERRORPATH specifies where Slick tries to find the sources on compilation errors (parsed by Slick if capture == ON).
It's set to the directory you specify for e.g. the 'Build' command in your Project Properties -> Tools.
You may add some more (fixed) dirs to search in Project Properties -> Directories.

The latter issue is probably related to the shell setup. It seems that it doesn't understand the fancy escape sequences emitted by a certain shell script you use.
It has to do with Windows.
You can check your shell settings by using the appr. commands at the prompt in the 'Build' window (set, env, etc.) and compare them with the setup of a 'normal' (login) shell.

@see (
SlickEdit is probably using a different shell than your default shell.  Some shells have problems when used in for SlickEdit builds (piped input/output).  It looks like "sh" is used by default on Solaris.  The shell used in the build is in the macro variable "def_process_shell".  Either put your environment setting in ".bashrc" or try changing the def_process_shell macro variable (Macro>Set Macro Variable).

Good luck,

Title: Re: Basic questions
Post by: BZ on February 10, 2007, 07:56:51 pm
I have same problem as you do. I have Ubuntu 6.10. I was looking for my way to solve it. I do not understand the problem properly. I was comparing the settings of bash (command line set,env) with settings of build window in SE(set, env). The settings are same.  Well there are some additional variables but i would say that they are only to tell where SE is installed.
I did run same command in bash (command line) as in SE Build window .

gcc -c    -g -o "Debug/TestProjectHelloWorld.o"  "/home/ziggi/TestProjectHelloWorld.c";/usr/local/slickEdit/bin/vsbuild -signalport 9000 -signal "execute-post-build "~local

The responses I have are not same. It looks like there is something wrong with escape sequences in Build window.

/home/ziggi/TestProjectHelloWorld.c: In function ‘main’:
/home/ziggi/TestProjectHelloWorld.c:6: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘printf’

TestProjectHelloWorld.c: In function ‘main’:
TestProjectHelloWorld.c:6: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘printf’

I really like SlickEdit, Please help me to solve it
Thanks a lot

Title: Re: Basic questions
Post by: meitalr on February 11, 2007, 08:18:40 am

I don't know if this will help you, but I had a similar problem with the prompt line of my build window. (escape sequences for color were not decoded).
So I changed the prompt line to some "safe" sequence.
In my .tcshrc file I wrote:
if ($?VSROOT) then
             set prompt = "%B< %h %b%m%B %c2>%b"
Otherwise I set the fancy prompt.

VSROOT variable is used to identify if this is a shell opened by slikcedit, not very elegant, but it works.

Hope this helps.
Title: Re: Basic questions
Post by: BZ on February 11, 2007, 09:27:22 am
Hi meitalr,

Thanks a lot for help.

There has to be something definitely wrong with escape sequences. My Build window does not handle them properly. I have had the problem with prompt as well. It copy the prompt always twice. It looks like this

]0;ziggi@GreenWood: ~ziggi@GreenWood:~$   

Your way works for me, but I do not know how to handle the error output of compilation. There has to be easy way how to modify handling of escape sequences for Build window in SE.

Title: Re: Basic questions
Post by: cmcgavran on February 13, 2007, 04:43:22 pm
I had a similar problem with bad characters, and after reading through another thread on the topic, found that it was solved by adding the following to my .bashrc and then restarting vs.

export LANG=en_"US"
Title: Re: Basic questions
Post by: BZ on February 13, 2007, 11:31:12 pm
Hi cmcgavran,

Thanks a lot that works perfectly for me. Now my SE is just perfect.
Once more, Thanks