SlickEdit Community

Archived Read Only Forums => SlickEdit 2014 v19 beta => Topic started by: jporkkahtc on September 12, 2014, 07:22:07 pm

Title: B4, Backup History, versions
Post by: jporkkahtc on September 12, 2014, 07:22:07 pm

Select "Older"
Expand Older.
Click on one of the files in the top.


Check a file in the bottom pane that has only 1 version available.
(NOTE: Slick doesn't tell you -- but it should display in this pane the number of versions of each file that is available).


Click "Diff".
Slick complains "Only one version, want to view the oldest versions of the files?"
Slick complains again "YOu must have at least 2 versions....".


#1: The first error message (shown below) doesn't make sense - please explain what it means, or what slick is trying to do.
#2: I asked to view the oldest version (given that there is just one version, I'm not sure what "oldest" is supposed to mean) so the 2nd dialog complaining that I must have at least 2 versions doesn't make sense.
#3: The 2nd dialog should tell me which file it is complaining about.





Dialog #1
---------------------------
SlickEdit
---------------------------
The following files do not have enough versions for the selected date.


C:\Users\Joe_Porkka\Documents\Slick\18.0.1\keybindings\keychart.html




Would you like to view the oldest versions of the files?
---------------------------
&Yes   &No   
---------------------------




Dialog #2
---------------------------
SlickEdit
---------------------------
You must have at least 2 versions of a file to use this feature
---------------------------
OK   
---------------------------

Title: Re: B4, Backup History, versions
Post by: Dan on September 15, 2014, 01:16:13 pm
You have to have two versions of a file in backup history to use the diff feature.  This is to compare versions with each other.

The dialog about comparing with the oldest version is because you can select a version in the top that is older than the oldest file in the bottom that you selected to diff.  The idea is that you can view all the files at a certain point in time, but sometimes you don't have a version that old for a given file.  So you get this message.