SlickEdit Community

Archived Read Only Forums => SlickEdit 2014 v19 beta => Topic started by: TKasparek on September 23, 2014, 11:50:23 pm

Title: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: TKasparek on September 23, 2014, 11:50:23 pm
I'm using the following in the TortoiseSVN->Diff Viewer->Merge Tool:
vsmerge %base %mine %theirs -sc "%HOMEPATH%\Documents\My SlickEdit Config\19.0.0"
The base file is shown as -sc and not the base as expected which makes the merges not save to the base file.
If I remove the -sc and on to not have it load a configuration (I can't remember why I needed this... won't source code color correctly maybe?) it won't open vsmerge at all.

~Tom
Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: Dan on September 24, 2014, 02:24:29 pm
Try putting the -sc args first.
Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: TKasparek on September 24, 2014, 02:47:32 pm
I'll possibly have another merge later this afternoon and I'll give this a shot. Is this just a trial to get me through?

I shouldn't need the -sc args at all correct?
Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: Dan on September 24, 2014, 03:11:52 pm
You shouldn't need it unless you want to specify a configuration directory other than the default one.
Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: TKasparek on September 24, 2014, 05:04:25 pm
So this appears to be my issue, it looks like I've had this setup wrong all along. (I've only used is as a reference before the last few days) The arguments should be:
vsmerge [options] %base %mine %theirs %merged
Sorry for my confusion.

The /h command line argument for vsmerge in v18 shows help while it doesn't in v19. I couldn't find any argument information in the help files.

~Tom

Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: Dan on September 24, 2014, 05:26:07 pm
The /h command line argument for vsmerge in v18 shows help while it doesn't in v19. I couldn't find any argument information in the help files.
That sounds like something that needs repair.  Let me look at this.
Title: Re: Win7x64:B5 vsmerge doesn't seem to work correctly
Post by: Dan on September 24, 2014, 05:47:45 pm
Fixed for next drop.  Thanks for the report!