SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => Topic started by: lambertia on December 15, 2014, 09:45:31 pm

Title: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: lambertia on December 15, 2014, 09:45:31 pm
I fixed this with a sym link. On ubuntu the location appears to be /var/lib/dbus/machine-id

process 11552: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/usr/var/lib/dbus/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
  D-Bus not built with -rdynamic so unable to print a backtrace
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: Clark on December 15, 2014, 10:54:07 pm
What version of Ubuntu are you running?
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: lambertia on December 15, 2014, 11:07:10 pm
14.04 and 10.04

'/usr/var' seems odd to me. Isn't it normally '/var'?
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: Clark on December 15, 2014, 11:37:41 pm
Hmm...that's what I typically run. Are you running the 64-bit version?
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: lambertia on December 15, 2014, 11:41:15 pm
the 14.04 is 64, the 10.04 is 32 bit.

Neither of them have a /usr/var directory.
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: Clark on December 16, 2014, 03:51:10 am
/usr/var doesn't exist on Ubuntu 32 bit or 64 bit on my machines either. I have no problem running SlickEdit though. There's must be some other difference. Not sure what. I remember there being an ubuntu goof up related to dbus but I thought that was ubuntu 12. I vaguely remember seeing a problem with a particular update. I haven't seen it since though.
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: lambertia on December 16, 2014, 03:52:21 am
No biggy :)
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: SlickEdit Support on December 17, 2014, 10:59:51 pm
This has been seen in a basic (essentially headless) linux install that was missing some packages.

To fix it, run:

dbus-uuidgen > /var/lib/dbus/machine-id

If you don’t have dbus-uuidgen , it’s in the dbus package, which can be installed by issuing yum install dbus.
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: jvert on January 15, 2015, 06:14:32 pm
I have the same problem on x64 Ubuntu 14.04. There is no /usr/var/lib/dbus/machine-id, only /var/lib/dbus/machine-id.

I fixed it with a symlink, but it seems to be a new problem with 19.01.1.
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: sipho on March 22, 2015, 11:01:12 pm
Same issue here when installing 19.0.1.1 over 18.0.?.? on 64 bit Ubuntu 14.04. But only when run through an ssh client with X11-forwarding. Running it from the icon on Ubuntu's desktop worked fine. Creating a symlink /usr/var/lib/dbus/machine-id to /var/lib/dbus/machine-id "fixed" the issue. But version 18 worked fine without this.
Title: Re: 19.01.1 launch failed - 'Failed to open "/usr/var/lib/dbus/machine-id"'
Post by: zrax on July 18, 2016, 05:34:47 pm
It seems to be an issue with the included dbus library (bin/libdbus-1.so.3).  I removed this file, to force the system copy to be found, and slickedit works fine again (on both Ubuntu and RHEL6).