SlickEdit Community

SlickEdit Product Discussion => SlickEditĀ® => Slick-CĀ® Macro Programming => Topic started by: flethuseo on May 26, 2015, 12:50:52 am

Title: "Path not found" when loading macros
Post by: flethuseo on May 26, 2015, 12:50:52 am
I am trying to load a batch-macro with load commands. The file structure looks like this:

- load_modules.e
- align_chars
  - alignchars.e
- escape_string
  - string_paste.e

load_modules.e is in the current directory and then alignchars.e is in the align-chars
directory which is at the same level as load_modules.e

When I try to load the bach macro I get this error:
"Path not found"

   
Code: [Select]
        #pragma option(strict, on)
        #include "slick.sh"

        /**
         * Load emulations and commands.
         * Slick-C batch macro.
         */
        defmain() {
          load("align_chars\\alignchars.e");
          load("escape_string\\string_paste.e");

          return 0;
        }
   
Title: Re: "Path not found" when loading macros
Post by: flethuseo on December 25, 2015, 06:14:49 am
I don't know if I'm the only one for whom this doesn't work. Anyhow I found a note on the best practices document and it states that I need to set VSLICKPATH. I set it to the directory where my load_modules.e macro is, and still NO LUCK!
Title: Re: "Path not found" when loading macros
Post by: Clark on March 01, 2016, 02:49:43 am
Relative paths don't appear to work with load(). Try something like the following:

load(get_env('VSROOT')'macros/allignchars.e');