SlickEdit Community

Archived Read Only Forums => SlickEdit 2018 v23 Beta Discussion => Topic started by: jc44 on August 22, 2018, 02:48:55 pm

Title: B2: <end> doesn't work in brief buffer window
Post by: jc44 on August 22, 2018, 02:48:55 pm
<end> and <home> don't work in the buffer window (Alt-B in brief emulation). <up>, <down>, <pg-up>, <pg-down> all do so <home> and <end> not working seems odd.

Thanks

John Cox
Title: Re: B2: <end> doesn't work in brief buffer window
Post by: Clark on August 22, 2018, 07:23:04 pm
Maybe I'm missing something. When the textbox has focus, Home/End operate on the text box and not the list like it's does in all emulations. When the list has focus, Home/End goes to the top and bottom of the list.

Seems like we should add Ctrl+Home and Ctrl+End support since that's not ambiguous if the textbox has focus.
Title: Re: B2: <end> doesn't work in brief buffer window
Post by: jc44 on August 23, 2018, 10:29:01 am
No you aren't missing anything and ctrl-home/end already work. As it happens I never use the filter in that dialog so I didn't even think that they might affect that.  So I guess the current behaviour is fair enough.  However I will contrast the behaviour with the Open dialog (Brief Alt-E) where home and & end do what I expect.  Yes - I accept that all the behaviours make sense now I think about it, but I sort of use Alt-E & Alt-B interchangeably to select documents so I am easily confused by differences in behaviour within those boxes.

So in summary - user error

Thanks

John Cox
Title: Re: B2: <end> doesn't work in brief buffer window
Post by: jc44 on August 23, 2018, 10:57:57 am
Just ignore my previous remark about Alt-B & Alt-E working differently - I appear to be very confused. I could have sworn I tested my statement prior to making it, but it doesn't work like that now (and I guess it never did).

Sorry for wasting your time
Title: Re: B2: <end> doesn't work in brief buffer window
Post by: Clark on August 23, 2018, 12:46:13 pm
No problem. I could have sworn Ctrl+Home/Ctrl+End didn't work when I checked it. Works fine now.