SlickEdit Community

Archived Read Only Forums => SlickEdit 2018 v23 Beta Discussion => Topic started by: IkerAriz on September 24, 2018, 04:37:43 pm

Title: beta4 - backup history broken
Post by: IkerAriz on September 24, 2018, 04:37:43 pm
If I open the backup history for the current file, select an older version and save it with "Save As..." the result is a corrupt file. Most of the content is correct but some areas look like a mashup of lines/characters that come from the selected version and the prev version.

Regards,
Iker
Title: Re: beta4 - backup history broken
Post by: Dan on September 24, 2018, 04:39:24 pm
I've fixed a couple of problems in the diff that will probably fix it.  Is there any chance you can send me the archives?
Title: Re: beta4 - backup history broken
Post by: IkerAriz on September 26, 2018, 10:59:40 pm
See attached. The only change from the first version of the "taskm.h" file to the second was the addition of two lines to the comment block above the class declaration. When I save the first version the resulting file drops the last lines of the comment (ie, no longer valid c++).

Iker
Title: Re: beta4 - backup history broken
Post by: Dan on September 27, 2018, 02:35:22 pm
Which two lines.  Right now I'm trying it with the whole comment, which should produce the same case (but I'm not done yet, I have to verify the bug in B4 and try in the current build).
Title: Re: beta4 - backup history broken
Post by: IkerAriz on September 27, 2018, 02:40:23 pm
The two lines just above "class" keyword. Ie, the saved version looks like this:
Code: [Select]
* incremental processing.
class Taskm : public Model
{
Note the comment is no longer closed.
Title: Re: beta4 - backup history broken
Post by: Dan on September 27, 2018, 02:42:15 pm
The two lines just above "class" keyword. Ie, the saved version looks like this:
Code: [Select]
* incremental processing.
class Taskm : public Model
{
Note the comment is no longer closed.
This sounds like what you got from a bad backup history?  What lines did you add before saving?  Or is this what you added.
Title: Re: beta4 - backup history broken
Post by: IkerAriz on September 27, 2018, 02:51:23 pm
Here's (roughly) what I did...

I deleted my vsdelta directory, opened the file, made one small edit (I think I added a space to the comment) and then saved the file. This gave me the first backup. I then changed these lines:
Code: [Select]
* incremental processing.
*/
class Taskm : public Model
{
by adding two extra comment lines to this:
Code: [Select]
* incremental processing.
*
*
*/
class Taskm : public Model
{

Title: Re: beta4 - backup history broken
Post by: Dan on September 27, 2018, 03:09:48 pm
Can you send me a PM with your email address so I can send you my email address so you can send me your user.cfg.xml?  I don't want the processing on paste to have an effect.
Title: Re: beta4 - backup history broken
Post by: Dan on September 27, 2018, 08:15:26 pm
This is fixed for Beta 5.  Thanks to Iker for all his help with this off the forum.