SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => Topic started by: Ruslan_Sirota on September 07, 2006, 06:56:27 am

Title: Error tag parsing "Tag not found"
Post by: Ruslan_Sirota on September 07, 2006, 06:56:27 am
I have following code:

Code: [Select]
#define PACKED __packed

typedef PACKED struct _tag_AnyStruct
{
    int i;
    int j;
}AnyStruct, *PAnyStruct;


Now I am try find definition of AnyStruct and receive Message box "Tag 'AnyStruct' no found. You may want to rebuild tag file", however definition of 'PAnyStruct' is displayed without any problem.

And a second problem that the structure 'AnyStruct' is not expanding.

Title: Re: Error tag parsing "Tag not found"
Post by: Graeme on September 07, 2006, 10:11:09 am

I don't know if this will solve the problem but in the tagging options dialog box, click the "C preprocessing" button and try adding __packed and PACKED as #defines.

Graeme
Title: Re: Error tag parsing "Tag not found"
Post by: Ruslan_Sirota on September 10, 2006, 06:54:23 am
The adding __packed to "C preprocessing" not solved the problem.  :(
Title: Re: Error tag parsing "Tag not found"
Post by: Graeme on September 10, 2006, 07:00:19 am

If you haven't already, you could check this thread
http://community.slickedit.com/index.php?topic=382.0 (http://community.slickedit.com/index.php?topic=382.0)

Graeme
Title: Re: Error tag parsing "Tag not found"
Post by: Ruslan_Sirota on October 31, 2006, 05:53:37 pm
Hi
I don't found any suggestion of my questions in thread: http://community.slickedit.com/index.php?topic=382.0 (http://community.slickedit.com/index.php?topic=382.0).

But I just evaluate SlickEdit for bying. All my sources has typedefs as I describe above. In CodeWright I not have any problem with parsing this expression, maybe in commercial version + hot fixes this is bug fixed?
Title: Re: Error tag parsing "Tag not found"
Post by: Graeme on November 01, 2006, 10:35:14 am

Adding just PACKED to the preprocessing list with empty expansion text allowed Slick V11.0.2 to find the AnyStruct typedef and adding both PACKED and __packed with PACKED expanding to __packed was still successful in the definition being found for me.

The expansion of AnyStruct also works i.e.
AnyStruct t1;
t1.
- with auto completion enabled, pressing the "dot" after t1 above results in the members of AnyStruct being shown in a list.

Can you post the code and describe exactly what you do that results in the error message "you may want to rebuild the tag file".  Also, have you tried rebuilding the tag file or do you have "tag on save" enabled.

Graeme
Title: Re: Error tag parsing "Tag not found"
Post by: Graeme on November 01, 2006, 10:40:30 am

I just checked what happens when __packed is in the preprocessing list but not PACKED and Slick then fails to find the definition  - so...  add PACKED if you haven't already.

Graeme
Title: Re: Error tag parsing "Tag not found"
Post by: hs2 on November 01, 2006, 10:44:40 am
Graeme is absolutely right - as usual...
However - I just attach my (working) PACKED pre-processing config as screenshot.
1 picture could explain more than 1000 words.

HS2
Title: Re: Error tag parsing "Tag not found"
Post by: Ruslan_Sirota on November 01, 2006, 02:19:17 pm
Ok
Thank you very match now it's work.
I will be need add 'PACKED' & '__packed' to "C preprocessing".
Title: Re: Error tag parsing "Tag not found"
Post by: pearish on November 23, 2006, 12:20:41 am
I'm new to SlickEdit, and I'm having problems with tags. In particular, I can't jump to the definitions of many of the functions defined in files under the "/usr/include" directory, even though the files are listed when I look at the files supposedly being tagged. The functions I'm not finding, are not complex, nor do they involve use of macros. Here's one example:

Code: [Select]
void     gtk_init                 (int    *argc,
                                   char ***argv);

I realize this isn't much information to go on, but I don't understand SlickEdit enough to even guess what information would be useful for others to help me diagnose this problem

Any help would be appreciated.
~jeff
Title: Re: Error tag parsing "Tag not found"
Post by: hs2 on November 23, 2006, 09:46:08 am
If the prototypes are enclosed in sth. like #ifdef GTK ... #endif you've to add this #define to your file ext. setup -> Options -> Other -> C-Preprocessing to help Slick tagging the desired parts of the sources.

HS2