SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit® Core for Eclipse™ => Topic started by: blueboy on October 16, 2009, 12:22:23 pm

Title: Errors in Tagging found (add tree and symbols view)
Post by: blueboy on October 16, 2009, 12:22:23 pm
Hi all,


I have found three errors (or I missed the option settings) concerning tag feature:

1.
I can't add a tree with multiple file extensions in Contex Tagging Tag Files Dialog.
Add files works fine, add tree with single extensions works fine (e.g. *.js), but
add tree with e.g. two extensions *.js;*.php fails. The files won't be added to the
.vtg file!

2.
The workspace tag file can't be seen on symbols view AND the code completion didn't work.
I have written a context tagging for qooxdoo (javascript) and this works on SE 12 (Outline
and Code Completition). With Slick Edit Core I can see the Symbols in the Outline, but the
code completition didn't work. I can't check the symbols in the tagfile with eclipse,
because the *.vtg file isn't visible, but I have checked with listvtg projectfile.vtg
and the result look good:

listvtg: finished, 235 files, 117 classes, 3851 tags, 0 occurrences in infodesk.vtg


3.
If a file is opened the outline isn't updated. The outline content will only be seen if I click into
the Outline. THis isn't related to my qooxdoo outline, same is seen with e.g. .php module.



Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: Ryan on October 16, 2009, 08:47:30 pm
Just wanted to let you know that I have been looking into these, and that I'll get back to you as soon as I have a better idea of what is going wrong.

- Ryan
Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: Ryan on October 20, 2009, 02:55:46 pm
Quote
1.  I can't add a tree with multiple file extensions in Contex Tagging Tag Files Dialog.
...add tree with e.g. two extensions *.js;*.php fails. The files won't be added to the
.vtg file!

Save the attached version of stdprocs.e and load it via Macros > Load Module or by opening the file in Eclipse and hitting F12 (load).  This was actually a pretty nasty bug...the problem wasn't with adding multiple extensions (*.cpp;*.hpp worked fine for me right away), but adding *.php in general.  This should fix the problem...let me know.

Quote
2.  The workspace tag file can't be seen on symbols view AND the code completion didn't work.
I have written a context tagging for qooxdoo (javascript) and this works on SE 12 (Outline
and Code Completition). With Slick Edit Core I can see the Symbols in the Outline, but the
code completition didn't work. I can't check the symbols in the tagfile with eclipse,
because the *.vtg file isn't visible, but I have checked with listvtg projectfile.vtg
and the result look good:

The workspace tag file in the picture you attached is not valid, so maybe after rebuilding the workspace tag file, and using 'Add Tree' (which hopefully has been fixed by the hotfix), the Symbols view will show you the workspace tag file.  You have probably already done this but you can also close and open the Symbols view, and restart Eclipse to see if that has any effect.

As far as code completion goes, the first thing I would check is whether or not the context tagging you wrote works with SlickEdit v14.  You mentioned you wrote it for 12...but I'm not sure it will be compatible with SlickEdit v14 (which is the base for Core 3.5.0).  You can just download the trial for 14 if you want to test.  There might be some tweaks that need to be made to make it v14-compatible.

If it does work with SlickEdit v14...is it possible for you to either post what you've written here, or e-mail it to me if you don't want to post it?  Without seeing what is going on I'm not sure I'm going to be much help with this one...also I can have the resident tagging expert look at it if necessary.

Quote
3.  If a file is opened the outline isn't updated. The outline content will only be seen if I click into
the Outline. THis isn't related to my qooxdoo outline, same is seen with e.g. .php module.

This I've not seen...is it with every PHP module you have?  Is it with any other languages?  Is it possible that the Outline view doesn't have any information to display from that particular PHP module?  For example, with 'qooxdoo-0.8.3-sdk\qooxdoo-0.8.3-sdk\application\feedreader\source\resource\feedreader\proxy\proxy.php', the Outline view won't display anything.

Hope this helps.

- Ryan
Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: blueboy on October 22, 2009, 07:18:46 am
1. now it works to add php modules, thanks.

2. now the workspace is valid (icon is correct), but infodesk entries are not in the .vtg file, I have added a few files. The tagging is done in attached user.e. The function _FindLanguageCallbackIndex() is replaced at 5 locations, please check replace_findlanguage.txt. For the js extension the own tagging is done with user_vsjs_list_tags() (only first implementation), this still works fine in SE12. If I try to list the symbols from the databse I get following error:

"c:\Dokumente und Einstellungen\rh.LYNX\workspace 3.5.1\.metadata\.plugins\com.sl
ickedit.core\tagfiles>listvtg infodesk_trunk.vtg
listvtg: dbopen error status = -3903"


Outline is still fine (except update process), but code completition didn't work. I have added the .vtg file, the tags can be found in the file
with a text editor?
editor

3. error still seen, simple example drag and drop a file into slickedit (e.g. user.e), the outline isn't updated until I click into the outline window?

4. new error with Tag files -> Add Tree found. If the dialog is opened (check add_tree.jpg) and a path is selected the path won't be used
until a path is selected with the treeview and drive listbox!


- Robert


Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: Ryan on October 22, 2009, 06:27:40 pm
While I look at this, could you possibly supply me with a sample js file that makes use of the qooxdoo libraries, with an example of something to test for code completion?  Like "go to line 100 in the attached file, do 'this.', and you should see the following members in the list members dialog" or "go to line 150 in the attached file, do 'qx.', and you should see the following in the list members dialog".  Screenshots for what I should see, from SlickEdit v12, would work.

I've grabbed some example code off their website, for example the code for the login screen at http://demo.qooxdoo.org/current/demobrowser/#animation~Login.html , but I'm just not sure what I should be seeing for auto completions or list members...thanks.

- Ryan
Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: blueboy on October 26, 2009, 07:44:28 am
Hi Ryan,


I have added a zip with 2 modules. If you open the modules you should see a valid outline (check activitiesextern_outline.jpg) and if you
double click the cursor will jump to the correct line and position in the module. If you add these both modules for tagging you can go
to line 6 and type:


var t=infodesk.

code completion will offer infodesk.activities

var t=infodesk.activities.

code completion will offer infodesk.activities.Activities and infodesk.activities.Payroll

var t=infodesk.activities.Payroll

code completion will offer ... ._buttonExport or __setLImits(), ...

I have added the output from listvtag infodesk.vtg. (listvtg.txt).


All this has been tested with SE12.
Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: Ryan on October 26, 2009, 03:11:14 pm
Thanks for all the info...it really makes a big difference with a problem like this.  What you need to do is make your language support a little more like the documented way to add language support in v14.  We didn't have these facilities in v12, but now in v14 things have changed.


You now have a supported language mode.  You should see correct list members when you do '.' (see attached picture).  Is this all correct now?  After I restarted Eclipse I wasn't seeing the problem of having to click in the Outline view, either, to get it to update.  Let me know about this one too...

Hope this helps,

Ryan
Title: Re: Errors in Tagging found (add tree and symbols view)
Post by: blueboy on October 28, 2009, 10:52:49 am
Hi Ryan,



using the language manager and own tagging functions is working fine.


--
BR
Robert