SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit® Core for Eclipse™ => Topic started by: lzimprint on June 03, 2010, 09:48:55 am

Title: slickedit core 3.3 unavailable for eclipse 3.5
Post by: lzimprint on June 03, 2010, 09:48:55 am

 I use link files to relate my slickedit 3.3 plugin to eclipse 3.5 .but it's not available.

encountered error below:
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle com.slickedit.eclipse.plugin (219).


Caused by: org.osgi.framework.BundleException: Exception in com.slickedit.eclipse.SlickEditPlugin.start() of bundle com.slickedit.eclipse.plugin.
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(
   at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(
   at org.eclipse.osgi.framework.util.SecureAction.start(
   at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(
   ... 57 more
Caused by: java.lang.Exception: SlickEdit Core Cannot Start.
   at com.slickedit.eclipse.SlickEditPlugin.start(
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl$
   at Method)
   at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(
   ... 62 more


Has anyone encountered such problem, i need your sharing .thanks

Title: Re: slickedit core 3.3 unavailable for eclipse 3.5
Post by: Ryan on June 04, 2010, 02:44:42 pm
I haven't tried running Core 3.3.1 in Eclipse 3.5.  In order to tell what the problem might be from that stack trace in the log file, I would need to see the bottom of the stack...where is has the root cause of the exception.  Unless that is the bottom of the stack, in which case it is no help.

Is there a particular reason why you are trying to run Core 3.3 in Eclipse 3.5, and not upgrading to Core 3.5.1?

- Ryan
Title: Re: slickedit core 3.3 unavailable for eclipse 3.5
Post by: k7zhang on June 10, 2010, 08:28:18 am
Hi, Ryan

Actually this problem does both exist in Eclipse 3.5 and 3.5.1. Could you pls repeat below steps to reproduct the erro scenario.
-  Create folder named "links" in eclipse root directory;
-  Place Slickedit core plugin in one place, e.g. c:\apps\slickedit_core_plugin, and its sub directory named as "eclipse". Copy all orignal Slickedit Core package into subfolder "eclipse";
-  Create one file and copy it in above "links" folder, which context should be like:
-  Open eclipse 3.5 or 3.5.2.
-  Collect log. It should repeat that error.

Title: Re: slickedit core 3.3 unavailable for eclipse 3.5
Post by: Ryan on June 10, 2010, 03:34:19 pm
I got this to work you can see from the attached screenshots, I have the plug-in installed in C:\apps\slickedit_core_plugin and Eclipse installed at C:\Eclipse Installs\eclipse-SDK-3.5.2-win32\eclipse.

I did exactly what you said (except I think I have lowercase "path" in my links file, instead of PATH).  There are 2 things I could think of that you might be doing wrong.

First, the plugins might not be extracted...they might still be .jar files.  Is the contents of C:\apps\slickedit_core_plugin\eclipse\plugins just a bunch of jar files?  If so, you need to extract each one into it's own extract com.slickedit.core_3.5.1.jar into com.slickedit.core_3.5.1.  Do the same for all plugins, and all features in the features/ directory.  Then nuke the .jar files.  Our individual plugins need to be extracted, and this is done automatically if you use the normal Eclipse install process, but it wouldn't be done automatically if you just downloaded the zip file from our website and extracted it and tried to run the product.

Second, do you have a com.slickedit.linux.libs_3.5.1 plugin sitting in the plugins directory?  You need to get rid of that...our plugin won't start if both the linux and windows native libraries are sitting there, because it thinks the installation has gone haywire.  Only one of these will be installed, depending on what platform you are on, if you use the normal Eclipse install mechanism...but if you are doing this manually you have to make sure that only one of these plugins (the one for your platform) exists.

Hope this helps.

- Ryan
Title: Re: slickedit core 3.3 unavailable for eclipse 3.5
Post by: lzimprint on June 11, 2010, 02:16:44 am

Thanks for your help.It works