SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit® Core for Eclipse™ => Topic started by: PlanetPratt on March 02, 2011, 08:42:45 am

Title: Can't start eclipse after VS16beta2-x64 install
Post by: PlanetPratt on March 02, 2011, 08:42:45 am
I recently installed the SlickEdit 2011 (v16) beta 2 64bit edition on my Windows 7 machine and now when I try to start eclipse (with SlickEdit Core for Eclipse installed) I get an assertion failure and it crashes eclipse.  Here's what I can see in the Slick-C Stack window (I can't cut & paste it since there's a modal assertion window that won't let the Stack window get focus):

Code: [Select]
Slick-C(R) assertion failure
DateTime.ex 295 se.datetime.DateTime.D
   1:   ._typename()=se.datetime.DateT
   1:   .m-ISO8601-DateTime=(null)
   2:   2011
   3:   2
   4:   0
   5:   8
   6:   34
   7:   3
   8:   .883
   9:   1

The modal dialog with focus is a Slick-C Error stating:

Code: [Select]
Slick-C(R) assertion failure: "validDate(year, month, day)" in file DateTime.e on line 148

file=DateTime.ex offset=295

I tried uninstalling SlickEdit but apparently the damage was done.  Is there any way to get my development environment back?
  (*Chris*)
Title: Re: Can't start eclipse after VS16beta2-x64 install
Post by: PlanetPratt on March 02, 2011, 08:59:21 am
Looks like I searched on the wrong keys trying to research this bug.  It turns out to be the same Leap Year bug everyone else was hitting.  I applied the patch, reset my date to Feb 28, loaded the patch, switched back to today and ran eclipse without a hitch.
  (*Chris*)