SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit® Core for Eclipse™ => Topic started by: Ryan on December 01, 2011, 07:54:50 pm

Title: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: Ryan on December 01, 2011, 07:54:50 pm
SlickEdit Inc. announces the release of SlickEdit Core v3.7.1 for Eclipse. This release supports Eclipse 3.4-3.7, and is updated with the latest capabilities from SlickEdit 2011.

If you participated in the beta program for SlickEdit Core v3.7.0, we recommend uninstalling the beta version of SlickEdit Core prior to installing the released version of SlickEdit Core v3.7.1.  You can do this through the Eclipse installation manager, but you should also check the ECLIPSEDIR/plugins and ECLIPSEDIR/features directories to make sure that Eclipse fully removed the beta.

New This Year

Please be sure to read the readme notes at Help > About SlickEdit Core > Release Notes. They contain a list of new features and bug fixes, including the following:

Download Instructions

Your existing SlickEdit Core license file will work for this release.  To install SlickEdit Core v3.7.1 (for Eclipse 3.5 and later):


or for Eclipse 3.4:


The download link for the offline installer can be found at: http://www.slickedit.com/trial/slickedit-core , if necessary.

Regards,
The SlickEdit Team
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: mattcole on December 02, 2011, 09:45:54 pm
Is there an ETA on the 64-bit plugin for Linux?

thanks,
Matt
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: Ryan on December 05, 2011, 02:37:25 pm
We definitely still want to add this platform, so hopefully in a future release this will be added.  Since we just released 3.7.1...I can't comment yet on our plans for our next major or minor release...but it is a high priority for us.

Thanks,

Ryan
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: mwilkins on December 07, 2011, 08:24:29 am
Is there anywhere to report bugs? I have found one already, all be it not important ( just reports the wrong path) reports the older com.slickedit.windows.lib_3.6.1\slickedit\macros directory ( which does not exist on my system!) even though it is looking in the com.slickedit.windows.lib_3.7.1\slickedit\macros directory see attached jpg
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: Ryan on December 07, 2011, 09:13:45 am
Seems like it's throwing an error compiling and older macro file you have.  I'll talk to another developer and see what the problem is when this type of thing arises.  I'll get back to you.

Feel free to report issues here or by directly submitting them to tech support at: http://www.slickedit.com/index.php?option=com_user&view=login&return=aHR0cDovL3d3dy5zbGlja2VkaXQuY29tL3N1cHBvcnQvb3BlbmNhc2U= .  Either way, it will probably find itself to me very quickly.

Thanks for the report.

- Ryan
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: brent on March 13, 2012, 04:50:19 pm
So..  I jumped the gun and dowloaded the trial for Eclipse on a 64 bit linux.. and it doesn't run.
( It is very clear in the system requirements that 32 bit linux is required.. I just didn't read it as
I was excited to try it out.. )
But.. now I can't run eclipse at all, it just dies at start up.
How can I easily remove the SE trial without reinstalling eclipse?
Thanks.
Title: Re: SlickEdit Core v3.7.1 for Eclipse Now Available
Post by: brent on March 13, 2012, 05:07:14 pm
Ok.. found the answer in this forum.. my apologies for not looking harder first
remove the com.slickedit* files in your eclipse directory (mine is in my home directory.. )

rm -rf .../eclipse/features/com.slickedit*
rm -rf .../eclipse/plugins/com.slickedit*