SlickEdit Community

SlickEdit Product Discussion => SlickEdit® => SlickEdit User Macros => Topic started by: namklak on August 31, 2012, 08:00:58 pm

Title: Old macros won't load with SE V17?
Post by: namklak on August 31, 2012, 08:00:58 pm
Hi,
I wrote some macros back in 2002 and tweaked a couple of them in 2009.  I started at a new company and installed SlickEdit V17, and SE complains "Unable to load module <file name>. Incorrect version."  How do I fix these macro modules?
Thanks,
-Bob
Title: Re: Old macros won't load with SE V17?
Post by: nhed on August 31, 2012, 09:54:02 pm
Bob,

Your post is so vague, I am surprised I am even answering it

I am guessing you are trying to load a .ex, not a .e file

please provide:
- File name, not just "<file name>" (to ensure you are not trying to load compile macros)
- A bit of the macro code - even if its empty (yes, try to load a no-op macro)

If this is the case, make sure you remove the .ex file, if this is not the case, at l;east post your macros and see if anyone has more advice

--Nevo
Title: Re: Old macros won't load with SE V17?
Post by: Graeme on September 01, 2012, 12:50:51 am
I had this problem too.

http://community.slickedit.com/index.php/topic,8387.msg35806.html (http://community.slickedit.com/index.php/topic,8387.msg35806.html)