Author Topic: -sc invocation option not working correctly  (Read 230 times)

TKasparek

  • Senior Community Member
  • Posts: 231
  • Hero Points: 27
-sc invocation option not working correctly
« on: December 20, 2019, 05:06:04 pm »
I'm trying to do a side by side comparison to rebuild my configuration directory. I did the following:
1. Renamed my current config directory "24.0.0 Old" (as well as moved all other configs out so it doesn't migrate, I did see there is a -migrate but this just seemed easier)
2. Opened SE and generated the default config.
3. Invoked SE with vs +new -sc "path\24.0.0 Old"
1 and 2 didn't really matter to this but 3 generated a copy of "24.0.0 Old" at "24.0.0 Old\24.0.0"
My understanding is -sc should just use the configuration at that location, or build a new one there.

Quote
SlickEdit Pro 2019 (v24.0.0.8 64-bit)

Serial number: WMX110555
Licensed number of users: Single user
License file: C:\ProgramData\slickedit\24\slickedit.lic

Build Date: October 2, 2019
Emulation: CUA

OS: Windows 10 x64
OS Version: 10.00.0 
Memory: 24% Load, 7926MB/32442MB Physical, 10944MB/37306MB Page File, 5367MB/134217727MB Virtual
Shell Information: C:\WINDOWS\system32\cmd.exe /q
Screen Size: 1920 x 1080, 1080 x 1920, 1080 x 1920

Project Type: Cpp
Language: .cpp (C/C++)
Encoding: Automatic

Installation Directory: C:\Program Files\SlickEdit Pro 24.0.0\ (non-removable drive,NTFS,328575MB free)
Configuration Directory: C:\Users\thomas.kasparek\Documents\My SlickEdit Config\24.0.0 Old\24.0.0\ (non-removable drive,NTFS,328575MB free)
Migrated from: C:\Users\thomas.kasparek\Documents\My SlickEdit Config\24.0.0 Old\

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5152
  • Hero Points: 425
Re: -sc invocation option not working correctly
« Reply #1 on: December 20, 2019, 05:49:02 pm »
-sc specifies the outer config directory. Versioned subdirectories are created inside the outer config directory.

TKasparek

  • Senior Community Member
  • Posts: 231
  • Hero Points: 27
Re: -sc invocation option not working correctly
« Reply #2 on: December 20, 2019, 06:31:02 pm »
Hmm. Ok, I can work around that. Thanks!