Author Topic: C++ Tagging list-symbols (alt-dot) problem  (Read 381 times)

jaymmartin

  • Community Member
  • Posts: 56
  • Hero Points: 8
C++ Tagging list-symbols (alt-dot) problem
« on: June 28, 2021, 07:37:42 pm »
Lately have been having trouble with this getting:
"Unable to locate definition of expression type: "<a parameter name>"

The parameter is defined  "const AType&  aParamName". 

"push-tag" (Cntl-.) Allows me to go to the definitions correctly.

Latest version 25.0.2.0. Already tried deleting and making new project.

Jay Martin
« Last Edit: June 28, 2021, 07:48:36 pm by jaymmartin »

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3434
  • Hero Points: 465
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #1 on: June 29, 2021, 03:42:51 pm »
How is "AType" defined?

jaymmartin

  • Community Member
  • Posts: 56
  • Hero Points: 8
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #2 on: June 30, 2021, 06:02:10 pm »
It looks like the issue is that AType, a simple class in another namespace, is
being used via a "using ANamespace::AType".  If the parameter type is
changed to "ANamespace::AType" then  "list-symbols" works.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3434
  • Hero Points: 465
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #3 on: June 30, 2021, 07:17:37 pm »
The next logical step is to figure out why the using statement is not being seen.  Is it preprocessed?  Is it hidden in a side-effecting include file? 

jaymmartin

  • Community Member
  • Posts: 56
  • Hero Points: 8
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #4 on: June 30, 2021, 09:21:06 pm »
The "using" is being pulled in from another header file.
#ifndef HEADER_H
#define HEADER_H
namepace AnotherNamespace {
using ANamespace::AType;
}
#endif
-------------------
#include "header.h"
namespace AnotherNamespace {
    AType aVar;
}

aVar. // No symbols found error

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3434
  • Hero Points: 465
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #5 on: June 30, 2021, 09:47:41 pm »
OK.  I will look into this one.  Thanks for helping drill down on exactly what was going on.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3434
  • Hero Points: 465
Re: C++ Tagging list-symbols (alt-dot) problem
« Reply #6 on: August 31, 2021, 02:14:53 pm »
Sorry, it took a while for this to filter through my queue, but this bug should be fixed for version 26, BETA 3.  It was not hot-fixable.