Author Topic: Icons for User Toolbar  (Read 7208 times)

rdauben

  • Community Member
  • Posts: 25
  • Hero Points: 0
Icons for User Toolbar
« on: August 02, 2006, 05:30:10 pm »
I have defined a couple of custom tools and placed them onto a custom toolbar.  I created multi-format icon files for the commands which are displayed correctly. My problem is that when I resize the toolbar (small, medium, large) my custom icons do NOT get resized like all the standard ones.  Is there something I'm missing in defining my icons?  I haven't found anything in the Help files about icon requirements or how to create them.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3471
  • Hero Points: 466
Re: Icons for User Toolbar
« Reply #1 on: August 02, 2006, 05:42:31 pm »
The icons should be Windows ICO files with (at minimum) the following sizes and color depths:

    16x16, 8-bit color
    24x24, 8-bit color
    32x32, 8-bit color

If you look in the "bitmaps" folder of your SlickEdit installation, you will find all the ICO files that we use.  We also include 32-bit color versions in all sizes, though we currently only use the 256 color versions.

The final requirement for resizing is that the name of your icon start with "bb" (for button bar).

rdauben

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Icons for User Toolbar
« Reply #2 on: August 02, 2006, 08:35:57 pm »
Thanks for your quick reply.  I finally got it to work with your help.  BTW... I'm using version 10.0.1.

The secret was the "bb" prefix.  I also discovered that the icon file must reside in C:\vslick\bitmaps.  I had been trying to keep it in my configuration directory.  I could browse to it and select it OK, and it displayed correctly initially.  But it could not be found when I tried to resize the toolbar.  Maybe that's a bug. (?)

Thanks again.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3471
  • Hero Points: 466
Re: Icons for User Toolbar
« Reply #3 on: August 02, 2006, 08:54:52 pm »
Actually, it just needs to be on your bitmaps path.  If you want to keep it separate from c:\vslick\bitmaps, just add the additional directory to your VSLICKPATH (defined in vslick.ini, located in your configuration directory).

rdauben

  • Community Member
  • Posts: 25
  • Hero Points: 0
Re: Icons for User Toolbar
« Reply #4 on: August 03, 2006, 12:51:53 pm »
I can't seem to get it to find my bitmaps in my VSLICKCONFIG\bitmaps directory, even though I have confirmed it is in the VSLICKPATH correctly by opening a shell window and entering the SET command to print all variables.  Oh well... I can live with putting my bitmaps in with all the standard ones.

Thanks.
Ron