Author Topic: Help. Unwanted Autocompleting  (Read 1757 times)

Negator

  • Community Member
  • Posts: 7
  • Hero Points: 0
Help. Unwanted Autocompleting
« on: June 05, 2011, 03:12:46 pm »
I am editing a new .py file

Autocomplete is turned off.

When I type "b" then space , it is autocompleted to "break".

When I type "c" then space a dialog "Select a Ke..." is displayed.

This happens in both default and Visual C++ 6 emulations.

All I want to do is type.

This is very annoying.

Help Plz.
« Last Edit: June 05, 2011, 03:14:40 pm by Negator »

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Help. Unwanted Autocompleting
« Reply #1 on: June 06, 2011, 02:19:31 pm »
That feature is called Syntax Expansion. It works on keywords rather than symbols in your code, like functions and classes.

When you type 'b' followed by space, you should see a notification in the lower right-hand corner of the screen that says, "Feature Notification: Syntax Expansion has been performed". If you click the little down arrow in the notice, it will bring up the options page for Syntax Expansion. If the notice goes by too quickly, you can click the document option for a list of recent automatic actions performed by SlickEdit. Select one of the lines and then click the wrench icon to go to Syntax Expansion options. Or you can configure it for the current language by selecting Document > Python Options, then select the Indent node in the tree.

You can turn Syntax Expansion off by unchecking "Syntax Expansion", or you can make it a little less agressive by increasing "Minimum expandable keyword length to 3 or 4.

Keep an eye out for those notifications. We've tried to put them in for anything like this that you might find surprising to help you figure out what's going on.