Author Topic: Symbol tab is not updating  (Read 3777 times)

Ranophile

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Symbol tab is not updating
« on: December 21, 2006, 10:42:24 pm »
Hi all,

I am using SlickEdit 10.0.3.  I love this editor, and have had very few problems.  However, I have a real headache now. 

A coworker came over to my PC, and to help them I switched the emulation mode on SlickEdit to Emacs from brief.  When I switched it back, I discovered that the symbol tab is "broken".  Previously, when I clicked on a symbol in a source file, the symbol tab would automatically update to show the symbol definition(s).  Now, the tab only updates if I click on it (it copies the symbol to the "Symbol:" edit box and shows the definition(s)).  I checked all my settings, and they have not changed.  The "show symbol under cursor" checkbox is set.  Cycling it did not help.  I searched through the help system to no avail.  Has anyone seen this problem?

Thanks,
Adriano Baglioni

Graeme

  • Senior Community Member
  • Posts: 2444
  • Hero Points: 322
Re: Symbol tab is not updating
« Reply #1 on: December 22, 2006, 01:48:02 am »

I couldn't reproduce this wth either 10.0.2 or V11.

Do you have any definite steps for reproducing it?  If not, you could try creating a brand new config directory and see if you can reproduce it there  i.e.
1. create a new empty directory abc;
2. invoke slickedit with the switch -sc abc to make slick use abc as the config folder (go help->about to see which config folder is active)
3. start with brief, then switch to emacs then back to brief to see if the problem appears.

If that doesn't produce the problem, make a copy (vusrdefs-1.e) of vusrdefs.e (or vunxdefs.e) in the abc folder, then copy in vusrdefs.e from your current config folder.  On the slick command line, type the full path and name of the vusrdefs.e file and press return.  Then see if the symbol window is updating as you want  - if not, compare vusrdefs.e with vusrdefs-1.e to see what is different.

Other things you could try are
1. Exit slickedit.  Backup your current config folder if not already.  Delete vslick.sta in the config folder.  Start slick and see if the problem has gone.
OR
2. type fp _UpdateTagWindow on the slick command line - it should take you to tagwin.e.  Try rebuilding tagwin.e - use "load module" on the macro menu.
OR
3. check the setting of "update toolbars after ms idle" value on the tagging options dialog (tools -> options -> tagging options).  Verify this against the value of def_update_tagging_idle by typing set-var on the slick command line, then enter def_update_tagging_idle as the name and press return to see its value.

Graeme

Ranophile

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: Symbol tab is not updating
« Reply #2 on: January 03, 2007, 05:10:03 pm »
Hi Graeme,

Thank you for your help!  I tried the first fix you listed: deleting the vslick.sta file.  This worked: SlickEdit now updates the symbol pane automatically.  I tried diff'ing the old and new vslick.sta files, but they are *very* different.  I will try the "alternate config directory" test to see if I can duplicate the brief->emacs->brief problem with the new, working vslick.sta file.  I'll let you know what I find.

Adriano

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2932
  • Hero Points: 438
Re: Symbol tab is not updating
« Reply #3 on: January 12, 2007, 07:46:17 pm »
Just a quick tip.  The majority of your configuration settings are stored in vusrdefs.e in your configuration directory.  If you want to diff for changes, try that, since the state file (vslick.sta) is a binary file.