Author Topic: V17 Searching in Options dialog in Linux is broken  (Read 1506 times)

Teknomancer

  • Community Member
  • Posts: 28
  • Hero Points: 1
V17 Searching in Options dialog in Linux is broken
« on: June 16, 2012, 01:08:29 pm »
Using the search field in the Tools->Option dialog box on Linux (64-bit) build of SlickEdit is broken.

Sometimes it doesn't perform any search i.e. just blanks out the dialog and doesn't update the search results list. Sometimes it does work but double-clicking the search result list item doesn't do anything (i.e. doesn't open the specific page)

The word I searched for was "overview".
« Last Edit: June 16, 2012, 01:15:51 pm by Teknomancer »

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 36
Re: V17 Searching in Options dialog in Linux is broken
« Reply #1 on: June 18, 2012, 01:41:39 pm »
I get no results from "overview," but I think that's because there are no instances of that term in the options.  Do you know of a place where the search should be finding it, but is not?

Double-clicking on results when I get them seems to be working for me.  Do you have a specific reproducible case for that issue?

Teknomancer

  • Community Member
  • Posts: 28
  • Hero Points: 1
Re: V17 Searching in Options dialog in Linux is broken
« Reply #2 on: June 20, 2012, 04:26:53 pm »
You are correct but here is what I found.

Type "overview" then backspace till you have "over", then type "view" again. Now the dialog doesn't seem to be updated and has stale contents from "over" and double-clicking doesn't open anything...

This is not a biggie though because the searching works well in all relevant cases :) I just happened to bump into this unusual sequence which isn't difficult to workaround anyway.

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 36
Re: V17 Searching in Options dialog in Linux is broken
« Reply #3 on: June 20, 2012, 05:24:08 pm »
Ah, I see what you mean now.  That is indeed a bug, and I will log a defect for it.

Thanks for reporting this!