Author Topic: Bizarre bug: suddenly can't find the letter "m" but can fing "abcdefghijk"  (Read 3331 times)


  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
This is under 64 bit Ubuntu 13.10 (running in Vmware under Windows 8.1 if that matters). It first happened under v16 but upgrading to v18 made no difference.

The installation has worked fine for three weeks but today "find" could not find text in a file which I knew was there and could see. I reduced the problem down to where I could see that "i" was matched but "m" was not. I created a new file containing "abcdefghijklmnopqrstuvwxyz" and find worked normally. If I pasted the test sequence into the failing file and search for an "i" it is not found in sequence but an "i" in  "int" on the next line is matched.

Suspecting a corrupt installation of some kind (and wanting to upgrade to v18 anyway) I blew away /opt/slickedit and installed v18.0.1.2. The project opened as normal but the crazy behaviour persists. The bug persists across a reboot (VM and the real PC). Case-sensitive, whole-word and regex are all "off". The file is just a small cpp file, 1058 lines.

As far as I know SE does not cache an internal representation of the working files in some cache file. If it does I could clear that cache.

Any ideas?

-- Sipho

SlickEdit 2013 (v18.0.1.2 64-bit)

Serial number: VLXxxxxxx
Licensed number of users: Single user
License file: /opt/slickedit/bin/slickedit.lic

Build Date: August 12, 2013
Emulation: CUA

OS: Linux
OS Version: Ubuntu 13.10
Kernel Level: 3.11.0-12-generic
Build Version: #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013
Processor Architecture: x86_64

X Server Vendor: The X.Org Foundation
Memory: 28% Load, 1468MB/5067MB Virtual
Shell Info: /opt/slickedit/bin/secsh -i
Screen Size: 2400 x 1350

Project Type: Gnuc
Language: .cpp (C/C++)

Installation Directory: /opt/slickedit/
Configuration Directory: /home/sipho/.slickedit/18.0.1/


  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
I resolved this (for now) by moving ~/.slickedit to another name and recreating my config by going through the initial configuration dialogs. Since the symptoms first appeared in v16 and continued after I upgraded to v18 something in my v16 config must have become corrupt and was imported into v18.


  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 100
  • Hero Points: 21
Double-check to ensure no Color options are enabled; that is usually a culprit when some matches are found while others are not.
(The "Color..." button in the Find and Replace dialog should say "Colors: None")